Skip to main content

SN3

Equipment

  • nycmesh-sn3-n3k:
    • ssh admin@10.70.95.8 -oKexAlgorithms=+diffie-hellman-group14-sha1 -m hmac-sha1
  • nycmesh-sn3-n5k:
    • ssh admin@10.70.95.10 -m hmac-sha1
    • Ubiquiti password
  • nycmesh-sn3-sw1:
    • Cisco Catalyst 3560-E Series Switch
    • Connects to n5k using 20Gbps LAG (Po5, Te0/1-2)
    • ssh admin@10.70.95.11 -oKexAlgorithms=+diffie-hellman-group14-sha1 -c aes256-cbc -m hmac-sha1

image (1).jpg

Configuration

To make changes, type enable and reenter the password.

View the setup

Show interfaces:
nycmesh-sn3-sw1#show interfaces description
Interface                      Status         Protocol Description
Vl1                            admin down     down
Vl34                           up             up
Fa0                            down           down
Gi0/1                          down           down     member - DanielHeredia
Gi0/2                          up             up       member - DanielHeredia2
Gi0/3                          down           down     sw-store01:C0:eth4:MGMT
Gi0/4                          down           down     sw-store01:C1:eth4:MGMT
Gi0/5                          up             up       logan-ucs-01-cimc
Gi0/6                          up             up       logan-ucs-02-cimc
Gi0/7                          up             up       member niche.horse oob
Gi0/8                          up             up       member myf ipmi
Gi0/9                          up             up       member daniel cloudkey
Gi0/10                         up             up       member micro raspi - crichton
...
Te0/1                          up             up       Po5:nycmesh-sn3-n5k:Eth1/25
Te0/2                          down           down     Po5:nycmesh-sn3-n5k:Eth1/26
Po5                            down           down     Te0/1-2:nycmesh-sn3-n5k:Eth1
  • Fa: Fast Ethernet (100Mbps)
  • Gi: Gigabit Ethernet (1000Mbps)
  • Te: Ten-Gig Ethernet (10000Mbps)
  • Po: Port-Channel (LAG/LACP)
Get the VLAN config for access ports (untagged):
nycmesh-sn3-sw1#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/33, Gi0/34, Gi0/35, Gi0/36
                                                Gi0/37, Gi0/38, Gi0/39, Gi0/40
                                                Gi0/41, Gi0/42, Gi0/43, Gi0/44
                                                Gi0/45, Gi0/46, Gi0/47, Gi0/48
                                                Te0/2
5    VLAN0005                         active    Gi0/2
32   nycmesh-sn3-members              active    Gi0/1, Gi0/5, Gi0/6, Gi0/7, Gi0/8
                                                Gi0/9, Gi0/10, Gi0/11, Gi0/14
                                                Gi0/15, Gi0/16, Gi0/17, Gi0/18
                                                Gi0/19, Gi0/20, Gi0/21, Gi0/22
                                                Gi0/23, Gi0/24, Gi0/25, Gi0/26
                                                Gi0/27, Gi0/28, Gi0/29, Gi0/30
                                                Gi0/31, Gi0/32
33   nycmesh-sn3-public               active
34   nycmesh-sn3-oob                  active    Gi0/3, Gi0/4, Gi0/12, Gi0/13
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
5    enet  100005     1500  -      -      -        -    -        0      0
32   enet  100032     1500  -      -      -        -    -        0      0
33   enet  100033     1500  -      -      -        -    -        0      0
34   enet  100034     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
  • Access: Untagged on an outbound VLAN
  • Trunk: Multiple outbound tagged VLANs
Show the configuration of a particular port:
nycmesh-sn3-sw1#show run int Po5
Building configuration...

Current configuration : 140 bytes
!
interface Port-channel5
 description Te0/1-2:nycmesh-sn3-n5k:Eth1/25-26
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

nycmesh-sn3-sw1#show run int Gi0/2
Building configuration...

Current configuration : 123 bytes
!
interface GigabitEthernet0/2
 description member - DanielHeredia2
 switchport access vlan 5
 switchport mode access
end

Make changes

To make changes, type configure terminal or conf t (shorthand)

Then, select an interface by typing in interface GigabitEthernet 0/2 or int Gi0/2 (shorthand)

Various VLAN config permutations
  • Access port only
    • switchport access vlan <vlan>
    • switchport mode access
  • Trunk mode
    • switchport trunk encapsulation dot1q
    • switchport mode trunk
    • Add or remove VLANs
      • switchport trunk allowed vlan add <vlan>
      • switchport trunk allowed vlan remove <vlan>
      • switchport trunk allowed vlan all
      • switchport trunk allowed vlan none
    • (if you want a native [untagged VLAN, PVID]) 
      • switchport trunk native vlan <vlan>

To make the changes persistent, type copy running-config startup-config or copy run start (shorthand).